
Introduction to Photoshop

“Image processing should never add anything to the image. In general, the role of the various 
processing operations is to remove or reduce one portion of the image contents so that others may 
be better seen or measured.” 

   – John Russ

Programs such as Photoshop and ImageJ, among others, are used to minimize defects in otherwise correctly 
obtained images. Images may also have structures enhanced or diminished for analysis.

Images may be processed for presentation purposes or for subsequent analysis 

FYI
Background Information Only



Image Defect Examples

Uneven background
illumination

Noise & scratches

Color imbalances

Contrast issues
Squawk!



Tool bar

Tool attributes
Palettes in
reserve

Palette

Photoshop Workspace

[Set number 
of undos in 
Preferences]



Selection

Eraser

Scroll & mag.

Move

Paint

Dodge & burn

Line (arrow)

Foreground & background
color

Crop

Measure

Photoshop Toolbar

Text

Swap colors

Default



Photoshop Toolbar (cont.)

Tools with black arrowheads in the 
lower right corner have related but 
hidden tools

Click with mouse 
to change colors

.



Menu options 
(drop down box)

Palette options

Trash

Palette Parts



Palettes
Rulers &
guides

Median,
smooth &
sharpen

Color modes &
Image adjust;
Image size

Fill &
transform

Frequently Used Photoshop Menu Items



Photoshop ‘Image’ Menu

*- Items discussed in lecture

*
*

*
*

*

*

*

*
*

*
*

*

*

*

*



Pixels

❑Pixel = picture element

❑Smallest unit of a digital image

❑Properties
• Usually square
• Location
• Dimension (if calibrated)
• Color or brightness value

Tile mosaic



Resampling refers to: 
• combining pixels into a larger ‘super-pixel’
• subdividing a pixel into smaller units
• Important!!: Note that the pixel dimensions (nm, mm, etc.) will change

A related concept is binning during image collection to:
• Increase collection speed
• Increase signal-to-noise ratio
• Decrease file size
 [Reduced spatial resolution]

Resampling

1 unit 4 units

Resolution is set during 
image collection and 
cannot be increased by  
subdividing a pixel into 
smaller units later.
  - BP



Resample off Resample on

Image pixel
dimensions

Image print
dimensions

File size

Resampling images

*

*

Anti-alias filter reduces
stair-stepping artifacts

*

Image > Image Size



Optical resolution describes the ability of an optical system to distinguish 
between two closely spaced points.  It depends on the alignment of the 
illumination system, quality of the objective lens and collection system, 
and the suitability of the specimen and its preparation. It is ultimately 
limited by diffraction.

Image (pixel) resolution is often considered the pixel count in a recorded 
digital image. An image with a high pixel count does not necessarily imply 
a high lateral resolution.



Layers

Layers can be thought of as individual images placed onto a canvas. Each layer is discrete and can be moved 
and edited independent of the others. This also applies to text and arrows.

• Layers can be rearranged, created, copied, deleted or hidden. 
• Layers can interact with other layers by changing their blending options and opacity. 
• Layers can be grouped, linked or merged together.  
• Layers can be filtered or enhanced independently.

Blending & opacity

Lock layer

Selected layer

Show/hide

Create, delete, etc.

*

Layer locked



Lets Build a Plate

File > New (define parameters) View > Rulers (if not visible)
Right click in ruler 
to change units



Select ‘Move’ tool
- Drag guides from the ruler 
- Hover tool to reposition 

Drag image onto plate with tool



Edit > Free Transform (CTRL+T)

Hold Shift and drag a corner handle to fit image Press Enter or select Apply icon when done

(resampled image after 
transform)



Image properly transformed 
by holding Shift and dragging 
from corner handle

Image improperly transformed 
by not holding Shift or 
dragging from a side handle

+ SHIFT

Free Transform



Hold CTRL+ALT and drag out several copies Add text, arrows, etc.
OOPS! Too late for scale bars

Arrow

Text



Crop

Crop image if desired

*To flatten layers use:
Layers > Flatten 

-Or-
Palette drop-down

Save Image

• Use *.PSD format to preserve layers
• Use *.TIF format to prevent 

compression artifacts

* View > Clear Guides



Contrast

• Contrast is the difference in brightness or color that makes an object distinctive from other objects and 
the background in the same field of view.

• The maximum contrast of an image (i.e. the darkest to brightest) is the contrast ratio or dynamic range. 

• Contrast is frequently expressed in terms of bit depth. A bit depth of 8 is common and gives us 28 or 256 
levels of brightness from black to white with 254 shades of intervening gray. Color images such as the RGB 
mode would have 8 bits per channel or a bit depth of 24 (224 = 16.8 million colors). Other common values 
collected by cameras include 10, 12 and 16 bits per channel.

• When collecting images it is preferred to acquire, as much as possible, the full dynamic range to ensure 
separation of small variations in brightness.



Modifying Contrast



Contrast & Brightness

Original Darker Brighter

We have decreased the dynamic range; data loss at extremes. Not recommended.

Image > Adjustments > Brightness/Contrast
*



Original Low contrast High contrast

• Low contrast - we have decreased the dynamic range
• High contrast - we have shifted the pixel values toward the extremes, eventually becoming a binary image.
• Again this is not recommended

Contrast & Brightness (cont.)

*



Dodge & Burn (in the darkroom)

Illumination after passing through film

Masks

Print

FYI

Dodge and Burn are used to change the exposure on localized areas of a print



Original Dodge tool (75%) Burn tool (75%)

• Some loss of dynamic range
• Histograms shift toward the extremes
• Not for the faint of heart

Dodge & Burn (cont.)



Levels
[Contrast enhancement, contrast stretch, histogram stretch …]

Image > Adjustments > Levels
(CTRL + L)

Original Histogram just short of utilizing full 8-bit



Levels (cont.)

After leveling
(Compare to original)

Move outer sliders to bracket 
histogram and perhaps a little 
more

Resulting histogram utilizing 
full 8-bit. Notice gaps in 
histogram – tell tale sign of 
enhancement

[Auto functions usually 
oversaturate, or ‘clip’, the extremes 
by at least 0.1%]



Gamma

A film’s response to light is shown on the D – log10E curve, where D is the optical density and E is the exposure

- Gamma is defined as the slope of the 
linear portion of the curve and is itself a 
logarithmic function

- A steep slope allows for greater changes 
in D from small changes in E resulting in a 
higher contrast image (greater dynamic 
range)

FYI



Gamma Adjustment in Image Analysis Programs

• Image analysis programs typically show g as 
a logarithmic curveGamma 0.5

0

255

INPUT

O
U

TP
U

T

• Pixel intensities are changed to a new value 
depending on where it lies relative to the 
curve

• Pixel order is retained

Resulting 
histogram

[Note: A curve is sometimes referred to as a transfer function]

FYI



Gamma Adjustment in Photoshop

Open Levels (CTRL+L) in the menu

• Gamma is the center slider. The default value is ‘1’

• Pixel order is retained

After g applied

• Maintains dynamic range if not applied too heavily

• Contrast expansion in part of the histogram, 
the rest is compressed

• No data loss!!!

• Original image can be restored by applying 
the inverse (e.g. g = 2.0)

>1 <1

[0.50][compress]

[expand]



Gamma Adjustment in Photoshop (cont.)

Gamma 1.8

• Contrast expanded in dark regions to reveal fine detail
• Contrast compressed in lighter regions
• No information loss!!

Original



Equalization

• Logarithms are not the only functions used to manipulate the contrast of an image.

• Gaussian, exponential and power functions can also be used.

• Equalization attempts to more evenly distribute the brightness values.

• Data clustered in peaks (small brightness variations) will spread out, while ‘valleys’ will compress.

Image > Adjustments 
> Equalization



Because human vision responds approximately logarithmically to brightness, it is often easier to 
discern details in the brighter areas of the original image when inverted (negative image).

Image Inversion

Image > Adjustments 
> Invert

FYI



Levels, including gamma, is the most commonly used 
and accepted method of contrast enhancement!



Digital Filters

• Digital filtering is a technique for modifying or enhancing an image.

• You can enhance, deemphasize or remove a feature.

• Filters are commonly used for edge detection, removing noise and to blur/sharpen an image.

• It is not uncommon to apply a ‘small’ filter several times (iteration) to reduce 
artifacts that a single ‘large’ filter might introduce.



Digital Filters

Square kernels

‘Circular’ kernal

00

0

0 0

0

0

0000

0

FYI

• A digital filter is a matrix of numbers

• This matrix is referred to as a kernel

• The filter is usually square but can be 
‘circular’ if zeroes are placed in the 
corners

• The filter performs math on the original image to 
produce a new one

• The numbers in the matrix weight the variables in the 
equation

• If the filter uses a math function it is sometimes 
referred to as a convolution. Otherwise it is a ranking 
filter



Filters (cont.)
FYI

• The filter is scanned over each pixel

• The central pixel is compared to its neighbors

• Math is performed using the weights in the matrix

• The central pixel is output to a new image that is constructed

• The next pixel is scanned and compared to its neighbors and 
so on until the new image is complete



Median (Noise) Filter

• Median filter uses the median value of the 
neighborhood to replace the central pixel

• Since noise tends to be an outlier value it 
should eventually be discarded

Original with salt/pepper noise

• Considered a ranking filter

• Fine detail can be lost

• Edges are preserved

• Large regions can take on the same brightness

{12, 12, 13, 14, 21, 23, 23, 23, 23, 29, 100}

Noise?
median

Filter > Noise > Median



Filter > Blur > Gaussian Blur

Smoothing Filter

3D Gaussian

2D Gaussian

• Mimics an out-of-focus condition

1 standard deviation

• Can reduce random noise

• Can blur and displace edges, and reduce contrast



Unsharp Mask Filter (in the darkroom)
FYI

Original 
film 
negative

Negative of 
original and 
slightly out-of-
focus film

g

Sharpened print image



Unsharp Mask (cont.)
Filter > Sharpen > Unsharp Mask

• Note artifacts: Graininess, halos and some edge shift

• Produces an increase in local contrast near points, lines and edges

• Minimizes noise enhancement

1 std. dev.

Strength or 
weight of kernel

Photoshop recommends:
• Amount 150% to 200%
• Radius 1-2 pixels



Scale Bars

• Open image
• View > Rulers if the rulers are not visible
• Right click on ruler to select ‘pixels’
• Layer > New > Layer
• Calculate length of scale bar in pixels

• Use the ‘Rectangular Marquee Tool’
• Change tool option to ‘Fixed Size’
• Enter scale bar dimensions
• Click on image (make sure new layer is selected)
• Edit > Fill with desired color
• Layer > Flatten Image



Scale Bars (cont.)

pixels



Scale Bars (cont.)

Original image with correct scale bar Same scale bar applied after resampling image

- Apply scale bars before resampling images!!



Arrows

• Use the ‘Line’ tool
• Tool options:

1. weight is stem thickness
2. arrowhead % based on weight



Text

Cancel/apply



Color Modes

Different color modes:

• RGB mode (millions of colors)
• CMYK mode (four-printed colors)
• Index mode (256 colors)
• Grayscale mode (256 grays)
• Bitmap mode (2 colors)

• RGB (Red/Green/Blue) and Grayscale are the most commonly used

• CMYK (Cyan/Magenta/Yellow/Black) used by printers

• Index color is an older mode used to save file space (8-bit color)

• Do not confuse grayscale conversion with desaturation

To confuse matters further, images using 
pixels are considered bitmap (or raster) 

vs. 
vector based images that use scalable 
Bézier curves (a Powerpoint shape is such 
a curve)



Grayscale RGB color

Color Modes (cont.)



Grayscale vs. Desaturation

Original color Desaturation Grayscale

Desaturation is usually defined as the average of the red, green and blue components:
(red + green + blue)/3

Grayscale is usually weighted to better fit human vision, and is the preferred method:
0.3% red + 0.6% green + 0.1% blue

Sometimes we want to change a color image to gray tones

Image > Mode > Grayscale

Image > Adjustments 
 > Desaturate

FYI



Color Wheel

Primary colors: red, green, blue

Complementary colors: magenta, cyan, yellow

• Hue = color

• Saturation = intensity 
of the color, or how 
much gray is mixed in

• Brightness = 
amount of black or 
white mixed with 
the color

R

G

B

y

c

m

Hue
Saturation

Brightness is the axis 
coming out of the plane 
of the page

Desaturation



Color Balance

Image > Adjustments > Color balance

Original • Primary colors opposite complementary colors

• Frequently seen in printer software

• Color artifacts and brightness shifts



Hue and saturation
Image > Adjustments > Hue/Saturation

Hue adjustment (color artifacts) Desaturation 
(loss of color 
information)

Darker (loss of dynamic range)original



Curves

Image > Adjustments > Curves    [CTRL + M]

The ‘Curves’ command acts like ‘Levels’ but gives you more flexibility than just black/white point and gamma

FYI

The ‘options’ sub-palette acts like 
Auto-Levels with a clip at the 
extremes of the histogram

Black, neutral gray, and white pickers (you just 
have to decide what is black/gray/white in the 
image)

*
*



Curves (cont.)
FYI

Points can be moved to manually 
set the white and black points

Points can be added 
and moved to make 
complex curves

input

o
u

tp
u

t



Curves (cont.)

• In this image the red is too predominant • Even with Curves the image is difficult to correct

• Note the uneven background in the upper left

• Empty areas still have a color cast• This should have been corrected at the microscope



RGB Color Mode

The RGB mode is one of 
the most commonly used 
for image collection

The Bayer filter on CCD 
cameras rely on red, 2x green 
and blue



HSI & Lab Color Modes

Color images present some problems for image processing and analysis
For this reason sometimes a color mode is chosen that has a brightness component

• Computer vision model

• Similar models include HSB, HSL & HSV

Hue, Saturation, Intensity

• Intensity component is White/Black vertical axis

L*a*b* model

• Computationally simpler model

• This mode is in Photoshop

• Lightness component is White/Black vertical axis

• a = green to red; b = blue to yellow• Hue expressed in degrees



L*a*b* Color

Image > Mode > Lab Color

Only L-component selected

[‘a’ & ‘b’ turned off using       icon]

This image can be processed without 
affecting the color component

When done, the ‘a’ & ‘b’ components 
can be turned back on and the image 
converted back to RGB Color

FYI



Applied to L-component of L*a*b* 
only and color added back

Applied to entire RGB imageOriginal

Unsharp Mask on Color Image

Note color artifacts



Contrast Enhancement (true or genuine colors)
e.g. Light Microscope

Original L-channel of L*a*b* 
color mode only

Each individual color
of RGB mode adjusted

For this type of image be careful when treating the colors as independent variables



Contrast Enhancement (color composite or pseudocolor)
e.g. Confocal Microscope

Original Final

green

blue

These types of images are independent grayscales that are combined and colored from a look-up-table (LUT)

Levels LUTs



False Coloring an SEM or TEM Image

• Open image and convert to RGB

• Draw a selection around an area of interest

• We will use the ‘red acetate’ method to 
make a selection. Anything that is red 
will not be selected.



Enter ‘Quick Mask 
Mode’



Brush size Brush

Black foreground

• Use Brush tool to 
paint around area 
of interest

• Do not worry if you 
make a mistake

• Adjust brush size 
as required



White foreground

• Use Brush with white foreground 
to correct any mistakes

• You could also use the Erase tool

Erase tool



• Return to ‘Standard Mode’

• Create a new layer

Standard Mode

New layer



Foreground Color

• Click on ‘Foreground Color’ 
and choose a color



• Edit > Fill

• Use: Foreground Color



Blending and opacity changed

Layer 0 unlocked (by double clicking) 
and ‘Levels’ performed on selection.

• Finish by flattening image and saving as *.tif

• Deselect the area and do another if you want

• Optionally lock the layer to prevent changes
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